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XPD TOOLS LAPSIM SOFTWARE - QUICK START GUIDE V1.0 

Introduction 
 
‘X-PD LapSIM’ is a vehicle simulation toolbox comprising a suite of software components which can be used 
for the detailed analysis of vehicle performance over a defined vehicle path. Utilising a comprehensive, non-
linear multi-mass vehicle model described by over 200 parameters & characteristic arrays it can be used to 
simulate and subsequently characterize a road or competition vehicles performance over a defined path in the 
virtual test environment.

1.0 Installation Instructions 
 
1. Run the XPDTools setup.exe install program. 
 
2. Choose the 'No Questions Asked Installation' option to install in default locations. 
 
3. Run the MCRInstaller.exe program and follow onscreen instructions*. 
 
4. Place your license file in the program root folder (default "C:/Program Files (x86)/XPD/XPD Tools"). 
 
5. Insert the dongle into a USB port and wait for windows to automatically install the correct drivers. 
 
6. Run the XPD Tools program from the desktop Icon. 
 
Notes:  
 
A valid dongle for XPD tools is required for the application to launch successfully; the dongle must remain 
connected to a USB port on your computer while the application is running for continued functionality. The 
license file and dongle are linked such that only the appropriate license file and dongle pair will allow full 
use of the software as licensed, it is not possible to mix and match license files/dongles. 
 
*The MCR installer program is located in the c:/Program files (x86)/XPD/XPD Tools/Support Files or can 
be downloaded from www.x-pd.com 
 
 

2.0 License Centre 
 

The License Centre is the main container application from which all other main software components and 
tools can be accessed; the License Centre GUI will open when the application is launched. 
 
The License Centre GUI is shown in Fig.1 – For full LapSIM functionality (including Motec I2 Pro data 
output**) the first 4 components must be enabled as shown in the figure, when the appropriate license file 
and dongle are in place the licensed components and details are displayed, each component can be 
launched by clicking the start button for the appropriate component (not applicable for the data conversion 
component). 
 
Notes:  
 
All software components that are open will close when the License Centre is closed, a warning will be 
given to confirm this and the intended application exit. **Motec I2 Pro API license is required for this 
functionality. 
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Fig.1 

 
Notes:  
 
The ‘File’ menu item allows access to the license file details dialog (shows details or indicates the absence/status of the file). 
 
The ‘Tools’ menu item allows for the refreshing of license status (required when new license file or dongle is installed while the software is 
running) and also allows for default file paths to be set – when the software is installed a directory structure is placed in the main users documents 
folder (named ‘XPD Tools’), there are sample application files contained in this directory structure so it is recommended that you select these 
directories as the default paths in the first instance. 
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Notes: 
 
Fig. 2 shows the modal dialog box for setting the default file paths, the path must be selected using the ‘Set’ button on the right hand side, and  
cannot be typed or pasted into the edit fields directly. Once the paths are selected the dialog can be closed by the red ’X’ in the top right hand 
corner (this is typical of any modal dialog box in the software). The nature of the ‘modal’ dialog box means it must be closed before continued 
use of the software is possible; this is applicable throughout the software. An audible tone will indicate a modal dialog is open and must be 
closed if another application dialog/window is clicked on. 
 

 

 
Fig. 2
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3.0 Vehicle Tool 
 

The Vehicle Tool is used for construction of the vehicle description and for detailed parameter setting. Split 
into separate vehicle ‘modules’ (chassis, tyres, suspension, engine, aerodynamics etc) every aspect of the 
vehicle which influences performance in the simulation is captured and can be individually defined, saved 
and re-loaded to build the complete vehicle. 
 
The Vehicle Tool GUI is shown in Fig. 3 – This GUI provides full control for building the vehicle definition 
and creating vehicle & vehicle module files. When initially loaded the software will warn that a vehicle file 
or a template file must be loaded, the toolbar shortcuts for creating a new vehicle file (by initially loading a 
template) or loading an existing vehicle file are enabled (while the other tools are disabled until a vehicle 
file or template is loaded). 
 
The vehicle templates provide a base structure consisting of a set of default parameters for a generic 
vehicle type; this provides a basis for constructing a new vehicle definition. A previously saved vehicle file 
can also be loaded initially. 
 
Notes:  
 
The ‘File’ menu item also provides the ability for vehicle and template files to be loaded into the Vehicle 
Tool. 
 
The ‘Tools’ menu item provides access to other functionality relating to the vehicle definition, for example 
for creating & editing gear ratio lists. 
 
 
 

 
Fig. 3 
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The following table shows the files extensions associated with the different file types used in the Vehicle 
Tool application. 

 
File Type: File Extension: 
Template *.xvtem 
Vehicle *.xveh 
Chassis Module *.xchs 
Tyre Module *.xtyr 
Engine Module *.xeng 
Gearbox Module *.xgbx 
Diff Module *.xdif 
Suspension Module *.xsus 
Aerodynamics Module *.xaro 
Brakes Module *.xbrk 
Gear Ratio List *.xrat 

 
 
Fig. 4 shows the Vehicle Tool GUI once a template file has been loaded, the shortcut toolbar is now 
available and the individual vehicle modules can be accessed through their respective shortcut buttons. In 
addition the gear ratio list shortcut can be used to bring up the gear ratio list management tool. 
 
The main GUI shows the vehicle description, drive type, layout and a summary of modules that compose 
the vehicle file. On the left side the ‘Altered Parameters’ list updates as changes are made to the vehicle 
parameters, providing a parameter change history, this is cleared once the vehicle model is saved. 
 
 
 

 
Fig. 4 
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Fig. 5 

 
Fig. 5 shows the Vehicle Tool GUI after changes have been made to the vehicle, the parameters that have 
changed appear in the ‘Altered Parameters’ list on the left side and the module field backgrounds change 
colour according to their status, to indicate if they are saved as individual files and/or into the vehicle file. 
 
 
Notes:  
 
When the mouse is placed over the shortcuts on the toolbar a tooltip is shown to indicate the vehicle 
module or function to which the shortcut relates (as shown in Fig. 5) 
 
When parameters are changed the background of the relevant module in the summary pane changes 
colour to red and the details/status changes accordingly, this is to indicate that changes have been made 
and are not saved. 
 
When the individual module is saved (through the file menu of the individual module GUI’s) the background 
changes to yellow to indicate the module has been saved as a module file BUT NOT into the vehicle file. 
 
When the vehicle file is saved all the field backgrounds in the summary pane will change to white, as they 
also do when a new vehicle file or template is loaded. 
 
When the module files are saved the status field changes to show the filename of the module file, this 
allows you to maintain a record of the components used in the construction of a vehicle file. 
 
It is recommended that previously created module files are not changed as a matter of course if this feature 
is to be used since this can cause confusion due to the fact that the individual vehicle files are independent 
and do not reference the module files themselves. 
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4.0 Circuit Tool 
 

This software tool is for the construction of the circuit path and geometry to be used in the lap simulation, 
the circuit profile is constructed and split into sections from existing track data (usually measured on car), 
this process is highly automated but the software also allows you to manually define local gradient, camber 
and grip variations to more accurately recreate the circuit. 
 
The Circuit Tool GUI is shown in Fig. 6 – The tool allows for the creation of a circuit from raw data or for a 
previously created circuit to be loaded for the purpose of running the simulation. 
 

 
Fig. 6 

 
Notes:  
 
Circuit or input files can be loaded via the ‘File’ menu item or the open file shortcut on the toolbar, for raw 
data a Matlab file or a CSV file can be used, the Matlab export from all major data analysis packages (i2 
Pro, Toolbox, ATLAS for example) can be used, and is recommended. 
 
 
To generate a new circuit from raw data the channels of lateral acceleration, speed and longitudinal 
acceleration are required to initially create the 2D path profile. 
 
Once a raw data file has been successfully loaded the channels within that raw data set will be available 
to select in the drop down lists of the ‘Input Data Setup’ pane, the correct channels (and respective units) 
should be selected here (See Fig. 7) in order that a circuit can be generated. 
 
A circuit name can be entered into the ‘Name’ field in the ‘Circuit Creation Setup’ pane and the correct 
source file frequency should also be specified here (as per the export from the original data set for 
example), it is then possible to generate the circuit profile by clicking the ‘Generate Circuit’ button, the 
circuit map will appear in the map window. 
 



LAP SIMULATION TOOLS   

 
© 2016 X-Performance Development Ltd 

 
X-Performance Development Ltd makes no representation or warranties of any kind as to the accuracy of the contents herein and specifically disclaims any implied warranties for the 
use of information supplied for any particular purpose.  X - Performance Development Ltd shall not be liable for any errors contained herein or for incidental or consequential losses in 
connection with the use of the information contained in this document, associated documents and information and/or related communications verbal or written. X-Performance 
Development Ltd - Registered in England No.  7110869 

 
Fig. 7 

 
 
Notes:  
 
The speed and lateral acceleration from the raw data used to create the circuit profile will appear on the 
bottom axes; this allows you to check the data used is of an acceptable quality. 
 
In the ‘Circuit Creation Setup’ pane there are settings to apply offsets, scalars and filters etc to manipulate 
the mapping and account for imperfections in the raw data, the ‘Generate Circuit’ button must be clicked 
to apply any changes made 
 
Circuit path curvature (point radius) is used by the simulation as a predefined vehicle path, this is derived 
from the speed and acceleration values, hence a ‘noisy’ input will result in a ‘noisy’ output, smoothing the 
raw data used to create the path profile within the Circuit Tool  will provide a more refined output. 
 
When the circuit profile is generated/re-generated any previously defined apex points will be deleted and 
will need to be re-defined. 
 
Once the circuit has apexes defined (see next section) it can be saved to file, the file extension denoting 
a circuit file created by the Circuit Tool is *.xcir. 
 
 

 
Once the circuit profile has been generated the circuit must be prepared for use with the simulation, this 
involves breaking the circuit into sections defined based on the corner apex points, thus the apex points 
need to be specified, this can be done by selecting the ‘Circuit Apex Points…’ item in the Tools menu. 
 
The Circuit Apex Definition window is shown in Fig. 8, (this is a modal dialog window) it allows the creation 
and editing of circuit apex points on the 2D circuit profile. 
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Fig. 8 

 

The Apex Auto Generate pane provides control for creating the apex points automatically; this is generally 
the best method to use. Default values in this pane are typically acceptable. Clicking the ‘Generate’ button 
will create the apex points, display them on the circuit plots as shown and list them in the right hand list 
box as well as on the raw data speed trace on the bottom axes. 
 
 
Notes: 
 
Apex points are generated based on path curvature, it is recommended to delete any apex points which 
are clearly not ‘true’ apex points based on the speed data trace displayed on the bottom axes. 
 
Noisy input data (particularly lateral acceleration) may give rise to additional apex points being generated 
erroneously; while these can be deleted it is recommended that applying a filter to the input data when 
generating the circuit profile will also help to yield better overall results. 
 
Apex points can be added and deleted as required although adding points which have not been auto 
generated is not advised as you may be placing them at points which are not minimum radius apexes. 
 
The ‘Sector View’ plot allows a more detailed view of circuit sections for editing apex points, the scale is 
specified in the ‘Sector Scaling’ pane, clicking on the full map will move the focus of the sector view. 
 
When the apex definition window is closed the main window plots are updated with the defined apex points, 
it is now possible to save the circuit file and/or use it for the lap simulation. 
 
The ‘Tools’ menu item in the main GUI provides access to the tools for editing localised circuit grip, camber 
and the elevation profile. 
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5.0 LapSIM Solver 
 

The LapSIM Solver is the tool used for implementing the solution algorithm based on a specified circuit 
and vehicle definition. A vehicle file created in the ‘Vehicle Tool’ application and a circuit file created in the 
‘Circuit Tool’ application can be loaded into the solver to run the simulations, or the solver can be set up 
to use the existing (currently open) circuit and vehicle definitions. The solver also allows ambient conditions 
to be specified and has options for solution resolution & convergence. 
 
The LapSIM Solver GUI is shown in Fig. 9 - The circuit and vehicle files to use can either be loaded into 
the solver application directly or the Solver can be configured to use the circuit and vehicle definitions that 
are currently open in the respective software components. 
 

 
Fig. 9 

 
To run the simulation simply click the ‘Start Simulation’ button, a progress dialog will appear while the 
simulation runs displaying relevant information and once complete the results are shown as in the figure 
and added to the run history list, lap time, Vmax, and Vaverage are displayed. The speed trace produced is 
shown in the axes below the results (in yellow), overlayed with the speed trace of the raw data used to 
generate the circuit path profile (in red) to allow a quick check of output quality or correlation. 
 
The ‘Stop Simulation’ button can be used to stop the simulation before it has completed, the solver status 
field in the ‘Simulation Control’ pane indicates the status of the solver and the duration of the last simulation 
run (time of calculation) is also displayed. 
 
Dependant on settings the software will ask if you want to save the results to file and for notes to add to 
the output data file once the simulation has completed. 
 
Fig. 10 shows the ‘Solution Setup’ dialog, this can be accessed through the ‘Tools’ menu item in the main 
Solver GUI. Parameters affecting the simulation and Solver functionality can be set here. 
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Fig. 10 

 
 
Notes: 
 
‘Solution Setup’ allows you to set the ambient conditions for the simulation, circuit & performance modifiers, 
solution & file options, the output type and the channels to output to file. 
 
Wind direction is specified in degrees from the straight ahead at the start-finish line (tail wind on the start-
finish straight) its angle is defined from this axis in a clockwise direction. 
 
The overall circuit grip scalar is applied in addition to any local grip variations that have been specified in 
the circuit definition. 
 
In the ‘Solution Options’ pane it is possible to select whether the currently open vehicle and circuit 
definitions are used for the solution, if these checkboxes are not selected the software will use the files 
loaded in the main Solver GUI.  
 
 
 
Access to the Solver Options dialog is also provided within the ‘Tools’ menu item of the Solver GUI, 
typically it should not be necessary to adjust these settings from the default values, as they effect solution 
resolution and can affect the results and/or cause the solution to generate different results. 
 
The facility to adjust them is provided in order to allow advanced users maximum scope to adjust the 
simulation control to suit the type of analysis being undertaken (for trade off of data resolution/convergence 
accuracy). 
 
It is possible to save the simulation session through the toolbar shortcut or the ‘File’ menu item, this session 
can be reviewed later and data files exported to the format of choice. The number of runs per session is 
limited to 20, after which the session must be saved or cleared to continue.  
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6.0 Analysis Export 

 
The data analysis export facility allows the advanced user to evaluate the results of a simulation in 
numerous ways. With multiple output formats it is possible to analyse simulation data as you would data 
recorded on a real race-car on-board system. Using for example time, distance or XY plots of the 
generated data (e.g. speed, ‘g’ forces, suspension displacements, contact loads, ride heights, etc) detailed 
post-processing of data and complete analysis of simulation results is possible alongside real car data 
within the users preferred analysis environment. 
 
The solver can output the Motec *.ld file format for the i2 Pro analysis software which provides extensive 
analysis capabilities. This facility requires the software installation has the appropriate license to integrate 
with the i2 Pro software (Motec API License). 
 
Other output formats include Pi Toolbox (Matlab dataset format) and MES ATLAS (Matlab session format) 
in addition to the XPD proprietary and standard CSV formats. 
 
Fig. 11 shows the sample output data displayed in Motec i2 Pro, data can be displayed and manipulated 
as with data recorded on a cars data logging system, including creating math channels and exporting to 
other formats. 
 

 
Fig. 11 

 
In the program root directory (normally "C:/Program Files/XPD/XPD Tools/Support" project/workbook 
templates are available for i2 Pro, Pi Toolbox and MES ATLAS, also within the ‘My Documents/XPD Tools’ 
file structure that was created on installation there are sample results files in these formats. 
 
 
Notes: 
 
Appropriate licenses are required in order to open the output files in the respective analysis software tools; 
these are not typically supplied with the LapSIM software and should be sourced separately. 
 

 



LAP SIMULATION TOOLS   

 
© 2016 X-Performance Development Ltd 

 
X-Performance Development Ltd makes no representation or warranties of any kind as to the accuracy of the contents herein and specifically disclaims any implied warranties for the 
use of information supplied for any particular purpose.  X - Performance Development Ltd shall not be liable for any errors contained herein or for incidental or consequential losses in 
connection with the use of the information contained in this document, associated documents and information and/or related communications verbal or written. X-Performance 
Development Ltd - Registered in England No.  7110869 

 
APPENDIX A – Simulation Data Output Channels 

 
Standard Output Channels: Std Unit: 

  

TIME/GENERAL PERFORMANCE/OTHER  

Time_Lap_Running Sec 

Distance_Lap m 

YawRate_Vehicle Deg/Sec 

TestOutput_Param NA 

  

DRIVER & CONTROLS  

Throttle_Position % 

Press_Brake_Front Bar 

Press_Brake_Rear Bar 

Angle_Steering Deg 

Angle_Steering_Ideal Deg 

  

BASE DATA  

Accel_Lat_Base g 

Accel_Long_Base g 

Speed_Ground_Base Km/h 

YawRate_Base Deg/Sec 

  

CIRCUIT  

Circuit_Radius m 

Circuit_Camber Deg 

Circuit_Grip Scaler 

Circuit_Gradient Ratio 

Circuit_X m 

Circuit_Y m 

Circuit_Z m 

  

SPEED/VELOCITY  

Speed_Ground Km/h 

  

DISPLACEMENTS  

Disp_Wheel_FL mm 

Disp_Wheel_FR mm 

Disp_Wheel_RL mm 

Disp_Wheel_RR  mm 

Disp_RideHeight_Front mm 

Disp_RideHeight_Rear mm 

  

ACCELERATIONS  

Accel_Lat g 

Accel_Long g 

Accel_Vert g 

  

LOADS  

Load_Contact_FL Kg 

Load_Contact_FR Kg 

Load_Contact_RL Kg 

Load_Contact_RR Kg 

  

ENGINE & TRANSMISSION  

Gear_Position Absolute 

Engine_RPM rpm 

Engine_Power Bhp 

Engine_Torque Nm 

Gear_Torque Nm 

Diff_Lock_Percent % 

  

WHEELS/TYRES/GRIP  
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Tyre_Slip_Front Deg 

Tyre_Slip_Rear Deg 

  

Optional Output Channel Subsets:  

  

WHEELS & TYRES - SUBSET  

Tyre_SlipLat_FL Deg 

Tyre_SlipLat_FR Deg 

Tyre_SlipLat_RL Deg 

Tyre_SlipLat_RR Deg 

  

Tyre_SlipLong_FL % 

Tyre_SlipLong_FR % 

Tyre_SlipLong_RL % 

Tyre_SlipLong_RR % 

  

Tyre_Sat_FL % 

Tyre_Sat_FR % 

Tyre_Sat_RL % 

Tyre_Sat_RR % 

Tyre_SatLong_FL % 

Tyre_SatLong_FR % 

Tyre_SatLong_RL % 

Tyre_SatLong_RR % 

Tyre_SatLat_FL % 

Tyre_SatLat_FR % 

Tyre_SatLat_RL % 

Tyre_SatLat_RR % 

  

SUSPENSION - SUBSET A (Springs/BR's & Roll Bars)  

Disp_Spring_FL  mm 

Disp_Spring_FR mm 

Disp_Spring_RL mm 

Disp_Spring_RR mm 

  

Disp_BR_FL mm 

Disp_BR_FR mm 

Disp_BR_RL mm 

Disp_BR_RR mm 

  

Disp_Spring_Fr3rd mm 

Disp_BR_Fr3rd mm 

Disp_Spring_Rr3rd mm 

Disp_BR_Rr3rd mm 

  

AERO - SUBSET  

Load_Aero_Front Kg 

Load_Aero_Rear Kg 

Load_Aero_Drag Kg 

  

Coef_Aero_Front NA 

Coef_Aero_Rear NA 

Coef_Aero_Drag NA 

Speed_Air Km/h 

  

LOADS & FORCES - SUBSET  

Load_LatTrans_Front Kg 

Load_LatTrans_Rear Kg 

  

MISC - SUBSET  

XPDDevParam_TS1 NA 

XPDDevParam_TS2 NA 

XPDDevParam_TS3 NA 
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